[Solved] Problems with Launcher

SSD was failing. So I copied my working game to another drive on computer,
I removed failing drive and thought I would re-download the launcher and game again on a different drive. I have got stuck at installing 96.7%. I can restart the launcher and it stuck always at this point. I have even loaded the previous working game and it still get to 96.7% and stops.
![alt text](0_1525687494452_62728cd3-8e81-4eb8-9016-01bd4a4acec6-image.png image url)
I have tried using both download 1 and 2 client same thing, Made sure that firewall etc was allowing this. still the same.
Any help is appreciated.

last edited by Eerye

There is an update right now, please re-launch the launcher and it should be good as new.

please help me… i cant update my game because the launcher said “Failed to download required file. It seems that an exception occured while trying to download the required file : An excemption occured during WebClient request…”. Thankyou

@archylah123 Restart the launcher or try using a vpn.

Thank you Lahn.
Was having Lahn (character) withdrawals had not played for almost 3 days. lol

Looks like your connection to OgreFest | Black Desert Online Private Server was lost, please wait while we try to reconnect.